The current version of Raspbian uses Jessie version of Debian. PHP7 isn't available on the Jessie main repository. In order to install PHP7, it is necessary to use the stretch release, which is a testing branch of Raspbian but stable enough for installing PHP7.

Update repositories

Modify apt repositories

sudo vi /etc/apt/sources.list

Add this line after the corresponding jessie.

deb http://mirrordirector.raspbian.org/raspbian/ stretch main contrib non-free rpi

Adding this line means that all software installations might tap into this branch. Remember that it's a testing branch, so let's make the Jessie branch the default one.

Create file /etc/apt/preferences with the following content.

Package: *
Pin: release n=jessie
Pin-Priority: 600

Update apt cache.

sudo apt-get update

Install PHP7

sudo apt-get install -t stretch php7.0 php7.0-curl php7.0-gd php7.0-fpm php7.0-cli php7.0-opcache php7.0-mbstring php7.0-xml php7.0-zip php7.0-mysql

-t strech tells apt to use the stretch release.